#general

2018年3月

 3月1日 

goat0時23分
@goatさんがチャンネルに参加しました
syui6時17分
@hirokazukisaragi よかったですね。他のLinuxとか使われてたんですか?
syui6時17分
@weelocko hi
hirokazukisaragi6時52分
Ubuntuを使っていました、リポジトリのパッケージ数の多さとローリング・リリースに魅力を感じたので移ってきました
syui7時5分
なるほど
weelocko12時0分
WeechatからSlackに入ってみたんですが、
意外と扱いにくいですね。
syui13時48分
なるほど、私は主にiOSとかのモバイルで使ってますね。
ここにCLIクライアントで入ってる人どれくらいるんだろうか
syui13時50分
確か kusanaginoturugi さんはCLIクライアントだった気がする
weelocko16時20分
一応、IRCからのGateway接続はBetaバージョン(https://archlinuxjp.slack.com/account/gateways)
らしいので、自分はSlackを使わなくなるかもしれませんが、返信してくださいましてありがとうございました。
God Bless syui!
acro5piano18時40分
自分も正にUbuntuからやってきました。よろしくお願いします。
raa012120時20分
こいつ、使いたいんだけど、aur なのか…
raa012120時20分
つら
raa012120時24分
``# github.com/lxc/lxd/lxc
/usr/lib/go/pkg/tool/linux_amd64/link: running gcc failed: exit status 1
/usr/bin/ld: /tmp/go-link-310683502/000004.o: 認識できない再配置 (0x2a) がセクション
.text' にあります
/usr/bin/ld: 最終リンクに失敗しました: 不正な値です
collect2: エラー: ld はステータス 1 で終了しました
```
raa012120時24分
んー
kusakata21時45分
Ubuntu製のツールですからね…AURのパッケージはバージョンがちょっと古いみたいですね
raa012121時46分
gcc が古いのが原因っぽいです
raa012121時46分
今 arch のシステムアップデートしてます

 3月2日 

n3k016時16分
@n3k0さんがチャンネルに参加しました
aomai23時42分
@aomaiさんがチャンネルに参加しました

 3月3日 

takumi.kt11時23分
あ。私もこないだハマったやつだ。。。あと、X11上で使ってる人は、gvimいらなくてもgvim入れないとクリップボードが使えない("*yが効かない)って罠もあったはず。。。 http://qiita.com/acro5piano/items/ec9f90548ede1f704e7a
syui11時26分
これはありますね。
私はデスクトップで使う場合、gvimをインストールします。+lua ビルドなどもついて便利
takumi.kt11時28分
いろいろ+がついてて便利なんですよね。ターミナルエミュレータ上でしか使わないですけど。
raa012111時29分
Arch のパッケージを諸々更新したら、LXDビルドできたー 時間かかったな
raa012111時29分
glibc2 やその他もろもろが更新されたので、anyenv シリーズで入れた各言語も再ビルドが必要でした
raa012111時30分
LXD は早くcommunity 入りしてもらいたい…
syui11時31分
ビルド、ものによってはすごく時間かかりますもんね
syui11時32分
communityに入ればダウンロードするだけなので速い
takumi.kt11時37分
Dockerと同じコンテナ技術を使って、用途としてはDockerよりはVirtualBoxに近い、みたいな位置づけなんでしょうか? >LXD http://keens.github.io/blog/2016/04/14/lxc_2_0_0gariri_susaretarashii/
syui11時38分
vim, 私もターミナルでしか使わないですね、gvimほとんど使ってない
raa012111時44分
そうですね Docker も前は LXC上で動いてましたし、VBox に近い感じですね
hirokazukisaragi12時1分
androidstudioインストールしたんですが
multilibリポジトリ有効にしないと開発環境作れないんですね
これでハマった方いれば参考までに
raa012112時3分
Android が基本 ARM なので、必要なのは確かに理屈的には通りますね
raa012112時4分
> Android Studio
>
> ADT プラグインのある Eclipse のように、Android Studio も開発とデバッグのための統合された Android 開発者ツールを提供しています。
>
> Android Studio は AUR の android-studioAUR パッケージでダウンロード・インストールすることが可能です。SDK が存在しないというエラーが表示された場合は、上記の Android SDK プラットフォーム API に関するセクションを見て下さい。
> ノート:
>
> i3wm 以外のタイル型ウィンドウマネージャを使っている場合、この issue ページに書かれているフィックスを適用する必要があります。
> Java 環境を設定していないと android-studio は起動しません。
raa012112時4分
確かに、wiki には記述がないですね
syui12時5分
pacman.confいじらないといけないパッケージ、稀にありますよね。
wineとか毎回ハマってる気がする
raa012112時6分
tad commented on 2016-12-11 01:37
@terusus Those are dependencies for the SDK, not for Android Studio itself. See the android-sdk and android-sdk-build-tools packages if you want Arch-packaged SDK tools.

terusus commented on 2016-12-05 16:59
mksdcard relies on additional 32 bit libraries:
lib32-ncurses
lib32-gcc-libs

It would be a good idea to add them to the dependencies.
raa012112時7分
SDK 側だって言われてますね
raa012112時9分
確かに、x86_64 だと、lib32シリーズが必要になってますね
acro5piano13時29分
すっかりはまってました。
なるほど、ターミナルでしか使わなくてもgvim入れるメリットあるんですね!

 3月4日 

myskng2時51分
@myskngさんがチャンネルに参加しました

 3月5日 

terut4時36分
https://bugs.archlinux.org/task/53147 これにやられました HAHAHA
syui10時31分
つらい

 3月6日 

sachin2119時6分
default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.


vagrant upしたらこんなエラーが出たんですが、vagrantのmasterでは以下のissueで1.8.6以降は修正されてるはずなんですが、ローカルのv1.9.2で、このエラーがでてvagrant sshができないんですが、解決された方いらっしゃいますか?

> https://github.com/chef/bento/issues/68

 3月7日 

sachin2115時2分
書き忘れていましたが、boxはこれを使っています。 https://github.com/2creatives/vagrant-centos/releases/v6.5.1
syui16時25分
難しそう
既に @sachin21 さんがいろいろ調べた上で動かないのだと思うので、何もアドバイスできませんが、検索してみたところ下のような記事がありました。

$ vagrant ssh-config

http://qiita.com/d2cdot-mmori/items/1c340f175ae510e4456a
syui16時28分
その他、私の場合、virtualboxのネットワーク設定など確認してみるかも...。
brackss116時35分
鍵生成時のバグですか?
sachin2117時1分
@brackss1 sshできない、という問題なので、鍵生成時に何か問題が起きてるみたいですね...
sachin2117時1分
@syui やっぱりその記事が一番怪しいですよね〜。
brackss117時2分
もう一回鍵生成してみたらどうですか
sachin2117時2分
でも、その記事の通りvagrant sshしようと思ったら出来ないんだったとショックを受けた
sachin2117時2分
鍵を再度生成するだけってデキましたっけ?
brackss117時3分
OpenSshで
syui17時4分
何らかのバグを踏んだ可能性(この場合、問題解決はユーザー側からは難しそう
sachin2117時4分
issue立てようかな…。
brackss117時5分
僕もvagrantでarch建ててるからその辺気になる
sachin2117時5分
vagrant内部で使ってる鍵をopensshで再度生成ってどうやるんだろう。。
syui17時8分
virtualboxでバックグラウンド起動せず直接起動してコマンド実行とかできます?
brackss117時9分
鍵はどっちも新しく作って書き換えることしかできない
sachin2117時10分
あ、そうか。VirtualBoxに入ればいいんですね
sachin2117時13分
あ、VirtualBox開いたらこんなエラーが出ましたね
VT-x/AMD-V hardware acceleration is not available on your system. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot.

全く違う問題なのかもしれない。。
syui17時14分
その場合、大体はvirtualboxの設定の問題ぽいかもですね。
sachin2117時15分
これっぽい
syui17時15分
なるほど
sachin2117時15分
今BIOS起動してます
sachin2117時19分
Advanceなんて項目無い...
brackss117時19分
再起動→F1かF2
clomsync17時19分
どこのメーカーですか
sachin2117時19分
BIOSは起動デキたんですけど、Advanceなんて項目どこにあるんだろ・・
syui17時20分
パソコンによって違った気がします
sachin2117時20分
LenovoのThinkPadです
brackss117時20分
全く同じ
brackss117時20分
確かAdvanceではなかった
syui17時20分
表記とかも違うことがありそう
clomsync17時20分
Security -> Virtualizationっすかね
brackss117時20分
それっぽい
sachin2117時20分
:sore:
sachin2117時20分
@clomsync ありがとうございます!
brackss117時21分
enableにする
brackss117時21分
仮想マシン使うときに最初に躓くとこ
clomsync17時21分
どういたしまして(?)
sachin2117時21分
Mac使いだったので、ここらへん気にしたことないんですよね...

 3月9日 

ignis20時44分
@ignisさんがチャンネルに参加しました

 3月10日 

mizunomi3223時16分
@mizunomi32さんがチャンネルに参加しました

 3月12日 

syui14時19分
xのデフォルトのカーソルアイコン変更ありましたっけ?
syui14時20分
ブラウザでリンク文字の時に表示されるアイコンが変わったような気がする
syui14時26分
それか前はテーマが設定されていて、それが反映されてないとかかな
syui14時30分
gtkとかxとかでnumixというテーマを設定してた気がするのですが、spacefm(アップデート-3)で一部反映されてないような感じにもなっているのですよね。
(またspacefmか...)
clomsync16時48分
デフォルトですか…確かにちょっと変わりましたね。
(十字矢印とかが変更された気がする)
syui16時52分
なるほど

 3月13日 

acro5piano9時33分
皆さん、Wifiの接続マネージャーって何かお使いですか?
ずっと wifi-menu で手動切り替えしてきたのですが、会社と自宅で同じPCを使うようになって、さすがに面倒になってきました…
AP認識して自動接続されるようにしたいと思っています。
acro5piano9時34分
ちなみにWMはAwesomeです。
syui9時35分
netctlですね、プロファイル作って切り替えます
syui9時37分
いや、これはそういうんじゃないかもですが。
network-managerなんかはguiでできるので良さそうですね(つかってないですが)
hirokazukisaragi10時7分
私はNetwork-managerでした、X入れる前はwifi-menu使ってましたが…
takumi.kt10時40分
networkmanager使ってます。自動接続もできてます。
taki-d10時55分
i3,awesome使ってましたら、
taki-d10時56分
これが良かったです
syui10時58分
ですね。networkmanagerにはこういうプラグイン?ぽいの結構あった記憶。
takumi.kt11時0分
へぇ、そんなのが。私はnm-applet使ってますが。ほんとにマウス触りたくない人にはいいかもしれないですね。
syui11時4分
nm-applet便利
sachin2111時7分
同じくNetworkManager使ってますね。XfceにもGUIで操作できるpackageがあるのでそれ使ってます。
acro5piano11時29分
皆さんありがとうございます!
それぞれ試してみます。
acro5piano11時58分
試した結果、CUIで制御したかったため、 @syui さんの netctl-auto を使うことに致しました。
今までネットワーク周りで起こっていた不具合もなぜか解決しました。本当にありがとうございます。

Wikiの下記の部分を参考にしました。本当に助かる・・・
https://wiki.archlinuxjp.org/index.php/Netctl#.E3.83.97.E3.83.AD.E3.83.95.E3.82.A1.E3.82.A4.E3.83.AB.E3.81.AE.E8.87.AA.E5.8B.95.E5.88.87.E3.82.8A.E6.9B.BF.E3.81.88

dmenu ファンなので networkmanager-dmenu も使ってみたかったのですが、力不足でインストールできなかったので諦めました。
clomsync12時59分
遅レスになりますが、Networkmanagerに確かnmtuiっていうCUI上で設定できるツールもありましたね(余談)
takumi.kt22時9分
nmcliしか知らなかったです。。。
clomsync23時5分
nmcliってあったんですね…tuiしか知らなかったです。。

 3月14日 

hsmt10818時54分
@hsmt108さんがチャンネルに参加しました

 3月15日 

meganetaaan9時22分
@meganetaaanさんがチャンネルに参加しました
meganetaaan19時19分
chromebookにインストールして開発用に使っています。よろしくおねがいします。
syui19時22分
こんにちは
chromebookにインストールしてるのレベル高いですね
clomsync19時59分
こんにちは、凄いです…

 3月16日 

yama2時1分
@yamaさんがチャンネルに参加しました
yama2時15分
翻訳すごいです。いつもありがとうございます。
fragment10時8分
certificates-utils 20170307-1 へのアップグレードは少し手動操作が必要なようです。
以下のニュースを参照してください。

和文
https://www.archlinuxjp.org/news/ca-certificates-utils-20170307-1-upgrade-requires-manual-intervention/

原文
https://www.archlinux.org/news/ca-certificates-utils-20170307-1-upgrade-requires-manual-intervention/
liseos_x14011時40分
@liseos_x140さんがチャンネルに参加しました
kusakata12時51分
@kusakataさんがメッセージをこのチャンネルにピン留めしました。
syui14時49分
今アップデートしました
syui14時50分
他の自動化してるやつとか大丈夫かな
terut16時24分
僕も無事行けました:triumph: 情報ありがとうございます!

 3月21日 

wpliao10時4分
@wpliaoさんがチャンネルに参加しました

 3月23日 

rana_mzk16時19分
@rana_mzkさんがチャンネルに参加しました
rana_mzk19時25分
ご挨拶が遅れました。知人がArch Linuxを試しているらしいと聞いてアップをしはじめました。ranaと申しますよろしくお願いいたします。
rana_mzk19時27分
普段はアメリカ人と音楽してます。
syui19時29分
こんにちはー
sachin2119時29分
よろしくおねがいします!
clomsync19時30分
こんにちは、よろしくお願いします。
rana_mzk19時30分
どうもです。よろしくお願いいたします。
rana_mzk19時30分
自己紹介がてらYouTubeのリンクですが音源をひとつ。

 3月26日 

osd9k15時22分
@osd9kさんがチャンネルに参加しました

 3月28日 

chris23時24分
@chrisさんがチャンネルに参加しました
chris23時28分
はじめまして!よろしくお願いします

 3月29日 

syui0時1分
はじめまして
botamochi1時48分
はじめまして
clomsync3時10分
はじめまして!よろしくお願いします〜

 3月31日 

deresmos8時14分
@deresmosさんがチャンネルに参加しました

 3月2日 

vector00820019時19分
@vector008200さんががファイル (ブート時の問題) をアップロードしてコメントしました : すみません 質問があります。現在ubuntu仕様のデスクトップpc(ssd)[os:ubuntu]→archにしたく、isoを焼き、USBで接続し、ブート先を光学ドライブにしたのですが、
root@archiso ~ #ではなく下記のようなエラーとともに始まるのですが、どうしたら正常にブートできるでしょう?
vector00820019時21分
一応デバイス互換の問題かなと思い、調べてみたのですが、ちゃんと認識されていたので多分ないと思い、次にisoイメージに問題があるかなと思い、再度焼き直しを試みましたが同じでした
clomsync19時23分
マウント時にディスク見えてないのかな…?
USBメモリがあるならUSBメモリを使った方が良いかもです…
(焼く時に使ったソフトを教えて頂けると助かります)
vector00820019時46分
焼く際は、braseroを使用しました
一応archブート時の選択画面で詳細が見れる所では、メモリ、ディスクssd&hdd、cpu、マザボ全て認識していたので認識はされてるはずだと思います。
USBでも試してみたいと思います。
atnanasi21時51分
マウント時にディスクのラベルで探そうとするのでISOを焼く時にARCH_201802という名前で焼く必要があったかと
clomsync21時51分
なるほど(名前変わるのか)
atnanasi21時52分
この場合ディスクがきちんと焼けているなら手動で/run/archiso/bootmntにディスクをマウントしてexitすれば大丈夫ですね
wataru.kikuchi022522時24分
@wataru.kikuchi0225さんがチャンネルに参加しました
ka.kaosf22時41分
@ka.kaosfさんがチャンネルに参加しました

 3月3日 

vector00820014時3分
なら、コピー先のdvdの名前を"ARCH_201802"にすれば良いんですね
有難う御座います。試してみます(^^)
atnanasi15時9分
焼き直さなくても[rootfs ]#の画面から手動でマウントさせれば続行できますよー
atnanasi15時11分
df -hでディスクの一覧を見てmount /dev/ディスク /run/archiso/bootmntしたあとにexitです
doc16時59分
@docさんがチャンネルに参加しました
vector00820021時36分
@atnanasi そうなんですか‼︎有難う御座います。情弱なので詳しく教えて頂き助かります(^^)

 3月6日 

js33ro4mrlv622時13分
@js33ro4mrlv6さんがチャンネルに参加しました

 3月7日 

hanuwai13032815時22分
@hanuwai130328さんがチャンネルに参加しました

 3月8日 

ryo.alter0時49分
@ryo.alterさんがチャンネルに参加しました

 3月15日 

ffcwx97110時27分
@ffcwx971さんがチャンネルに参加しました

 3月20日 

miyamoto.nya.takashi12時30分
@miyamoto.nya.takashiさんがチャンネルに参加しました

 3月21日 

huruya210016時47分
@huruya2100さんがチャンネルに参加しました
sky.sea.marine.blue19時32分
@sky.sea.marine.blueさんがチャンネルに参加しました

 3月22日 

ryoji.higami3時3分
@ryoji.higamiさんがチャンネルに参加しました

 3月27日 

vector00820020時56分
@atnanasi すみません df -h を試みたのですが、dvdしか認識されず、ssdが認識されませんでした。またusbで201803も試したのですが同じくusbしか表示されませんでした。
atnanasi21時0分
df -hだとマウントしているデバイスしか表示できないですね、正しくはlsblkでした
vector00820021時6分
@atnanasi 試してみます ありがとうございます
jun.bj14140023時17分
@jun.bj141400さんがチャンネルに参加しました

Arch Linux JP Slack コミュニティ

Arch ユーザーや Arch Linux に興味がある人なら誰でも参加できる Slack コミュニティです。詳しくはこちらを見てください。

ログ作成日時: 2018/04/01 12:28:22。