#general

2018年5月

 5月1日 

pasutisu21時24分
@pasutisuさんがチャンネルに参加しました
pasutisu21時28分
どうもはじめまして、日本語Wikiがforkしていることに気がついてやって来ました
syui21時28分
はじめましてー

 5月2日 

gentaro5時45分
@gentaroさんがチャンネルに参加しました

 5月6日 

connie22時39分
@connieさんがチャンネルに参加しました
connie22時46分
はじめまして。仕事のローカルPCの作業環境でarchを使うようになって興味を持ちました。よろしくお願いします。
syui22時47分
はじめまして

 5月12日 

gleb16時44分
@glebさんがチャンネルに参加しました

 5月13日 

tata14時42分
@tataさんがチャンネルに参加しました

 5月14日 

forestsource10時15分
@forestsourceさんがチャンネルに参加しました

 5月15日 

fragment20時33分
少し読み込んでいないので、雑な紹介になりますが
保守コストから abs パッケージがdropされ、 asp を使うようになった模様です。

詳細は以下のニュースを参照してください。

和文
https://www.archlinuxjp.org/news/deprecation-of-abs/

原文
https://www.archlinux.org/news/deprecation-of-abs/
kusakata21時20分
@kusakataさんがメッセージをこのチャンネルにピン留めしました。
kusakata22時6分
fragment: いつも素早い報告ありがとうございます。翻訳しました: https://www.archlinuxjp.org/news/deprecation-of-abs/
fragment22時9分
kusakata: 最近は翻訳・PRの方で力になれませんでしたが、役に立てたなら幸いです。

 5月16日 

ytarch14時39分
@ytarchさんがチャンネルに参加しました
ytarch14時41分
こんにちは
ytarch14時45分
fcitx-mozcをインストールしたら全角/半角キーが通用しなくなりました
kakakaya15時34分
fcitx-diagnose を使ってまず問題を診断してみましょう
ytarch17時34分
それでも通用しません
ytarch17時37分
使用しているのはManjaro LinuxというArch Linuxベースのシステムです
takumi.kt17時45分
fcitx-imが入ってないとか、GTK_IM_MODULEの設定してないとか、そういうオチないですよね?
clomsync18時4分
またはその類だとfcitx自体を起動してなかったり(?)
syui18時13分
hi
syui18時13分
キー入力できないの辛そう
syui18時17分
私ならxevなどでそのキーを確認し、xmodmapなどでそのキーを設定後にfcitx設定で見てみるとかかなあ
ytarch18時21分
@takumi.kt 私はQtを使っているのでQT_IM_MODULEの設定をしました
takumi.kt18時24分
全部やった方がいいですよ。GTK使ってるものは多いので。
ytarch18時27分
@takumi.kt Qt以外インストールしていません
syui18時28分
ドキュメントに書いてある通りはやってみました?
xinitrcなのですが
ytarch18時30分
@syui ~/.xinitrcをどうやって編集すればいいんでしょうか
syui18時33分
通常はエディタですが、インストールしてない場合はechoなどでいけるかと思います。
内容についてですが、 @takumi.kt さんが書かれているような環境変数とかになると思います。
=fcitx
ytarch18時36分
@syui ~/.bashrcではないんですね
syui18時36分
まあ、動かないならどっちもやってみたほうがいいかなと
syui18時37分
(あまり調べてないので適当)
takumi.kt18時39分
ディスプレイマネージャがSDDM (KDE5で推奨されているもの)なら、 .xprofileだったかと思います。
clomsync18時39分
https://wiki.archlinuxjp.org/index.php/Fcitx#.E3.83.87.E3.82.B9.E3.82.AF.E3.83.88.E3.83.83.E3.83.97.E7.92.B0.E5.A2.83
Wikiも結構書いてあることが複雑ですね(環境の違いで書くべき場所が違うみたいですね…)
hirokazukisaragi21時1分
cinnamon&GDM環境ですが、.xprofileに
export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS="@im=fcitx"
LANG=ja_JP.UTF-8
で動いています、参考までに
nomuken21時10分
マニュアルにもありますが ~/.bashrc に記述するとよろしくないので注意したほうが良いですね

 5月17日 

ytarch11時53分
あと、ECC(NIST P-521)の鍵ペアをgpgで生成するとSIGSEGVで止まるんですが
kakakaya13時23分
それはArch固有の問題ですか?それともOS問わず発生しますか?
fragment15時30分
ytarch: 最近、GNOME環境でインプットメソッドが動かなくなった際はGNOME on X.orgを一度動かしてからデフォルト(Wayland版GNOME)に戻ると動く現象が
今回はQtな環境ということで関連性は薄そうですが、参考までに。
fragment15時35分
混じらないようThreadに投稿したので…
ytarch16時57分
@kakakaya Manjaro Linux以外使用していないのでわかりません
syui17時1分
それはECCだけで発生する問題ですか?
ytarch17時1分
はい
raa012117時5分
ECC(NIST P-521) で鍵ペア作ってみたけど、普通に生成できた on Arch Linux
raa012117時7分
@ytarch -v を付けて実行してみてください
raa012117時8分
あ、違った Brainpool でやってた
raa012117時9分
どっちにしてもいけたな
syui17時13分
$ export GPG_TTY=/dev/console


とか

$ echo 'no-tty' >> ~/.gnupg/gpg.conf
$ GPG_TTY=$(tty)
$ export GPG_TTY


とかでやってみてください
syui17時14分
関係ないかもですが
sachin2118時18分
pacman壊したかもしれない…
opensslをダウングレードするためにpacman -U openssl 1.0.2 --forceしてしまった…
sachin2118時18分
NetworkManagerも起動しないため詰んだ
syui18時19分
つらい
sachin2118時21分
これはクリーンインストールしか手段無いですかね??
syui18時21分
ここです? force
sachin2118時21分
いえいえ
sachin2118時22分
英語のビギナーヘルプでしたっけ。
sachin2118時22分
そこで見て実行しました。
誤解与えてすみません
syui18時23分
よかった
sachin2118時23分
forceはかなり危険なんですね
sachin2118時24分
もう出社してしまっているので、代わりのPCが出せないため解決策何が思い当たりませんか
syui18時24分
そういえばこの前も動かなくなったというやりとりありましたね #random
nomuken18時24分
何が理由でダウングレードしたかが分からないで正確ではないかもですが, /var/cache/pacman/pkg に最新版残ってたりしませんか
sachin2118時24分
残ってます
nomuken18時24分
その最新版を force インストールはどうでしょうか
sachin2118時24分
pacmanが起動しません
nomuken18時25分
あー,なるほど
nomuken18時25分
エラーは何で落ちていますか?出力無しで異常終了ですか?
sachin2118時25分
cpなどは使えます
sachin2118時25分
出力をなんとかコピーしようとやってたんですが、手入力しますので上しょお待ちを
sachin2118時26分
少々お待ちを
nomuken18時26分
最悪tarファイルを解凍してPKGBUILD見ながら同じことをやるということも出来ないわけではないので,時間を書けてでも戻したいならそんな感じですね.もし,再起動できるのであればarchiso入れてpacstrapからpacman入れ直すと良いかもです
sachin2118時27分
pacman: error while loading shared libraries: libcrypto.so.1.1
sachin2118時27分
なるほど。
nomuken18時27分
あー,pacmanの要求のやつ合わなくなった感じですね
sachin2118時27分
pkgbuildやってます
nomuken18時29分
このやりとりが参考になりそうです
https://bbs.archlinux.org/viewtopic.php?id=95007
sachin2118時31分
いえたああああああ
syui18時32分
お、よかったですねー
sachin2118時32分
本当に助かりましたー!ありがとうございます!!
お二人ともウィッシュリストください
軽いものなんか送ります><
nomuken18時33分
お礼はぜひこちらにw https://www.archlinuxjp.org/donate/
sachin2118時33分
なるほど、その手がw
sachin2118時34分
これからこうしたらいいよというコメントがあっても公式ドキュメント以外forceは実行しないと固く決めた。
syui18時35分
お気遣い感謝です
(しかしリスト公開してないのと、私は何もしてない)
sachin2118時36分
なるほどwいえ、その解決したコメントを貼ってくださらないままだったらわたしの今日の日当がたぶん消えてました笑
syui18時48分
日頃から適当なこと言いすぎてるので、force書き込んだの自分じゃないだろうかとちょっとドキッとした
sachin2118時48分
わたしも言いそうなタイプなので逆の立場だったらそう思ってますねw
sachin2118時54分
ちなみに戦犯はこの方です https://bbs.archlinux.org/viewtopic.php?pid=1707651#p1707651

これを見ても絶対に--forceしてはいけない。。
sachin2118時55分
Do not --forceみたいなの書きたいけど、登録しないといけないのかな。
nomuken19時0分
英語全く出来なくて正しく訳せてないのでわからないのですが, I have moved /usr/lib/libssl.so.1.1 and /usr/lib/libcrypto.so.1.1 to a backup location and "pacman -Syu" now works. とあるので,対象ファイルを適当な場所に動かせば pacman -Syu が動く,のような感じだと思うのですが……
nomuken19時0分
間違ってたら申し訳ないです……
syui19時1分
ネットワーク繋がらなくなるの割とどうしようもなさありますよね
nomuken19時3分
そっちはどうしようも無いですね……,一時的にNetworkManagerを使わずにdhcpcd, netctlに一時的に切り替えたら……と思ったりもしますがopenssl周りはWiFi周りで使いそうなので解決策になりそうにないかもですね……
sachin2119時6分
わたしちょっと誤解してたみたいですね...
sachin2119時6分
--forceの後の手順が抜けたのか
syui19時7分
なるほど
でも試してみてダメだったのでは?
(具体的にはわかりませんが推測するに)
sachin2119時9分
でも、1.1のlibcryptoはそもそも存在してへんかった気がする。-Uした後。

sudo cp -f /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypt.so.1.1
これを実行したくらいなので、そもそも無いかった気がしますね。
nomuken19時11分
なるほど,不思議ですね……
syui19時11分
(ドキュメントはもう読まれてるだろうなとか、すでにこの手順は実行されてるだろうなとか勝手に推測)
syui19時14分
適当に推測した上で書き込むため、いつも相当的外れなことを書いてしまってるな自分...
sachin2119時19分
わたしの方で前提を書いてない場合ですし、手順やってるだろうな、というのはたぶん当たり前の推測だと思います。
syui19時21分
ありがとうございます、でも的外れなことよく書いてる気がしますね、笑
sachin2119時25分
わたしも的はずれなこと言う事あるので、何も言えないですw
aruneko9922時18分
えっと、この投稿をしたGilJさんは、pacman -Syuしたときに容量が不足していてOpenSSLだけがアップグレードされてpacman自体のアップデートには失敗してしまっていたようです。
ただこのときpacmanが要求するOpenSSLのバージョンが1.0から1.1に切り替わっていたようで、pacmanが古いままだったために実行出来なくなってしまったものと思います。
そこで、キャッシュに残っていた古いOpenSSLをインストールし直して、さらに中途半端にアップグレードされたpacmanをいったん古いバージョンのpacmanに再インストールしてからもう一度アップグレードしたら直った、という感じでしょうか。
sachin2122時28分
なるほどー
syui22時30分
GilJさんは間が悪かったぽい
syui22時31分
スマホからだとGilJさん、iなのかlなのかむずい
syui22時34分
多分真ん中が小文字なのか
syui22時40分
私もArchを触っていて何度か不運な事故に巻きこまれたことあったな...
sachin2122時51分
Archは本当気をつけないとシステムぶっ壊れますよね...。
disってるわけではないけど、サーバー用途としては絶対に使いたくないナという意思が芽生えてきた
syui22時55分
たまにありますね、なんかよくわからないけど
>> 何もしてないのに壊れた <<
みたいなのが
syui22時56分
まあ、大抵の場合、なんかやっちゃってるんですけどね
syui22時58分
私はサーバー用途として使ってます。
割と安定してますよ
他のOSでサーバー立てたことあまりないので確実なことは言えませんが

 5月18日 

nomuken0時25分
個人的にArchLinuxはどんなに壊れても不死鳥のように蘇る( == なんで壊れたかが分かりやすいため修正が容易)ので,大好きです.サーバーは結局コンテナベースにしちゃいましたがホストOSはArchLinuxです.
clomsync0時49分
アップデートなどの操作を面倒が見れる時間にやってしまえば良いのかもですが…
(Wikiにも「アップデートは慎重に」って書いてありましたね)
結構それは難しかったり
plain8時54分
私も最近、あまり使ってない端末を久々にアップデートかけたら壊れました。時間かければ直せるとは思いますが入れ替えたほうが早そう
clomsync13時1分
素のArchLinuxとかだとインストーラーがないので入れ直すのちょっと面倒ですね…
ガイドとか見ないとたまにlocaltimeのリンク張り忘れたり…
sunqiao15時40分
@sunqiaoさんがチャンネルに参加しました
aruneko9921時33分
localtimeといえば、最近クリーンインストールしたときに/etc/localtimeにすでにシンボリックが作られていたんですけれども、手動ではなくtimedatactlを使う方法が推奨されるようになったのでしょうか?
clomsync21時39分
そういえば確かに既に作られてましたね。
# ln -sf /usr/share/zoneinfo/Region/City /etc/localtime
って本家インストールガイドにも書いてありますが…(補完が効くので助かるのは助かる)
aruneko9921時51分
強制的に上書きするように促されるんですね...
clomsync22時21分
そのようですね

 5月20日 

ranko1時47分
@rankoさんがチャンネルに参加しました

 5月24日 

suascrow21時19分
@suascrowさんがチャンネルに参加しました
lespedeza9421時54分
@lespedeza94さんがチャンネルに参加しました

 5月25日 

syui19時40分
こういう場合、どうすればいいのかわからない...
syui19時41分
とりあえず短縮urlは迂闊に踏みづらい
sachin2119時42分
短縮urlは場合によっては使うべきではない
syui19時45分
私は踏みませんね、基本
調べてないのでわかりませんが、危険かもしれないし、広告ぽいので一旦削除後に出来る限りurlを表示してほしいみたいなことを伝えた方がいいのだろうか
syui19時56分
@sunqiao メッセージを投稿してくれてありがとうございます。
メッセージの内容の一部に短縮URLが含まれているのを確認しました。
短縮URL自体は禁止ではありませんが、今回の投稿に関しては、ちょっと内容がわかりづらかったため一旦、投稿を削除しました。
もしよろしければ短縮URLではなく本来のURLで再投稿いただけると助かります。
また、短縮URLを使いたい場合、その理由を添えていただけると嬉しいです。
煩雑な処理で申し訳ありません。

 5月27日 

glatan20時11分
@glatanさんがチャンネルに参加しました

 5月28日 

ytarch16時32分
gpgの機能がRSA以外壊れました

 5月29日 

tock20312時55分
@tock203さんがチャンネルに参加しました

 5月31日 

teruhikokada5時15分
@teruhikokadaさんがチャンネルに参加しました
teruhikokada7時0分
おはようございます。許容される時間ではないかと思いますのでご挨拶まで。
Archを使ってまる1年になりますが、主だった不具合に対応するWikiとトラッカーに助けられ、快適に暮らしてきました。
メディア経由でのリプレースもしやすく、移行性も高く、ポリシーもシステムも明快で好きです。
よろしくお願いします。
syui7時1分
よろしくお願いします
syui7時14分
気軽に書き込んでもらって大丈夫ですよ
teruhikokada7時34分
あ、なるほどw
入力中のまま離席していました。気をつけます.

ところで若干心配なのは、gpgだけ壊れるというのはシステム上あり得るのかどうかというところです。
Xorgの上に乗るものはまだしも、怖い状況になっていなければよいのですが。
syui7時55分
状況的によくわからないというのはありそう > gpg
関係ありませんが、実は最近、macで使ってるgpgの挙動がなんかおかしい気がするんですよね。なので、この辺あまりよくわからない...

 5月2日 

sei40kr10時11分
@sei40krさんがチャンネルに参加しました
hsui2x14時42分
@hsui2xさんがチャンネルに参加しました

 5月3日 

nitoli_reg2時59分
@nitoli_regさんがチャンネルに参加しました

 5月5日 

raa01218時58分
https://aur.archlinux.org/packages/ttf-cica/
このパッケージが古いので、OoDを出しべきなのか、コメントに最新を見るようにするdiffを貼り付けるべきなのか迷う
raa01218時59分
あと、OoDを出すなら英語のほうが良いのかな?
aruneko999時18分
メンテナンスを巻き取ってしまうという手も…?
aruneko999時19分
でも確かにCica2を入れて欲しいというのはありますね…
kusakata10時15分
新しいニュースが投稿されました。
js52パッケージを52.7.3-2に更新する際、/usr/lib/libmozjs-52.so.0を削除するようにしてください。

https://www.archlinux.jp/news/js52-5273-2-upgrade-requires-intervention/
原文: https://www.archlinux.org/news/js52-5273-2-upgrade-requires-intervention/

 5月6日 

hikanagix16時44分
@hikanagixさんがチャンネルに参加しました

 5月8日 

tunhuatian17時44分
@tunhuatianさんがチャンネルに参加しました
nanagami136920時22分
@nanagami1369さんがチャンネルに参加しました

 5月10日 

awsao90116時34分
@awsao901さんがチャンネルに参加しました

 5月11日 

takumi.kt8時52分
@takumi.ktさんがメッセージをこのチャンネルにピン留めしました。
takeiryou92623時18分
^ありがとうございます!

 5月16日 

vermilion92814時0分
@vermilion928さんがチャンネルに参加しました
nnhixi15時19分
@nnhixiさんがチャンネルに参加しました

 5月18日 

sachin2120時17分
yaourt -SyyuしてrebootしたらCUIログインでき無くなったんですが、パッと見で解決策わかる方いますか?
sachin2120時17分
とりあえず今USBブートできるようにiso落としてます
raa012120時22分
なんだろう 4/20 以降初めてなら、
https://archlinuxjp.slack.com/archives/C0GFH3RHC/p1524219385000180
ですかね
sachin2120時26分
うおお、04/20以降初めてですね
sachin2120時26分
ありがとうございます!
sachin2121時55分
Thank you so much! it's solved with https://archlinuxjp.slack.com/archives/C0GFH3RHC/p1524219385000180 :tada:
but IME has been broken I don't know why.

 5月21日 

igeitakuyaok16時22分
@igeitakuyaokさんがチャンネルに参加しました

 5月24日 

daisukeokahassou8時40分
@daisukeokahassouさんがチャンネルに参加しました

 5月26日 

takeiryou9262時49分
lib32-mesaのことわかる方います?
takeiryou9262時49分
なんかアップデートできなくて、インターネットの人々はlib32-mesaが直るまで待てと言ってる人が多いので。。
takeiryou9262時49分
もし、なにか情報あれば教えてください

 5月28日 

shima19850604mail15時29分
@shima19850604mailさんがチャンネルに参加しました

 5月29日 

fragment10時2分
既出の情報かもしれませんが、 pacman-optimize コマンドが core/pacman パッケージから消えていたようですね。
何かしらニュースとか出るかもしれませんね。
kusakata18時9分
pacman-contribにパッケージが分けられたようです

Arch Linux JP Slack コミュニティ

Arch ユーザーや Arch Linux に興味がある人なら誰でも参加できる Slack コミュニティです。詳しくはこちらを見てください。

ログ作成日時: 2018/06/01 12:28:13。